Monday, October 21, 2013

Unable to access Exchange 2013 EAC/ECP webpage



Error Message: -

Unable to access Exchange 2013 EAC/ECP webpage.

Exchange 2013 ECP error

The page cannot be display


Resolution: -

  •  First of all as we are habitual Check the Event Viewer whether we are getting any related events
  • Process MSExchangeHWWorker.exe (ExHMWorker) (PID=1124).ServerComponent 'RwsProxy' set by Requester 'HealthApi' to Inactive
  • Check whether Default Web site pointing to WWWRoot (c:\inetpub\wwwroot), if it’s wrong change it to default settings.
  • Check the ECP Virtual Directory configured correct Authentication, it should enabled windows authentication and form based authentication should be disabled.
  • Check ECP Virtual Directory configured correct physical location, in my case it was C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess\ecp.
  • Check the OWA Virtual directory and authentication; it should be Windows authentication and Physical location C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess\owa.
  • Check the Binding configuration in Client Access Server for post 80 and 443
  • Recreate the ECP and OWA Virtual Directory.


For the "OWA" virtual directory
  • Open Exchange Management Shell (EMS), and then run the following cmdlet to change the authentication method of the "owa" virtual directory to Windows authentication:
  • Set-Owavirtualdirectory -identity "MBX\owa (Exchange Back End)" -WindowsAuthentication $True -Basicauthentication $false -Formsauthentication $false
  • Run the following command on both the Client Access and Mailbox servers to restart Internet Information Services (IIS):  iisreset /noforce


For the "ECP" virtual directory
  • Start Windows PowerShell.
  • Type the following commands, and then press Enter after each line:
  • Add-PSSnapin *exchange*
  • Set-EcpVirtualDirectory -Identity "MBX\ecp (Exchange Back End)" -WindowsAuthentication $true -FormsAuthentication $false
  • Run the following command on both the Client Access and Mailbox servers to restart Internet Information Services (IIS): iisreset /noforce

 

No comments:

Post a Comment