Tuesday, January 3, 2017

RoutingMasterDN is pointing to an old server- Exchange 2013

I came the following errors in the Application Event Log in Exchange 2013 server:

Log Name:      Application
Source:        MSExchange ADAccess
Date:          12/16/2016 11:14:02 AM
Event ID:      2937
Task Category: Validation
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:      xxxxxxxxxxx
Description:
Process edgetransport.exe (Transport) (PID=32144). Object [CN=Exchange Routing Group (DWBGZMFD01QNBJR),CN=Routing Groups,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=xxxxxx,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=xxxxx,DC=xxxxx]. Property [RoutingMasterDN] is set to value [xxxxxxxx
DEL:67729122-b25b-4d4c-b5b0-75ad9e9dacd4], it is pointing to the Deleted Objects container in Active Directory. This property should be fixed as soon as possible.


Solution:

1. Open ADSIEdit and navigate to CN=Servers,CN=Exchange Administrative         Group (FYDIBOHF23SPDLT),CN=Administrative Groups,
    CN=domain,CN=MicrosoftExchange,CN=Services,CN=Configuration,  
    DC=domain,DC=com.

2. Right-click the Edge Transport server and copy the distinguishedName value.
3. Navigate to CN=Exchange Routing Group   
    (DWBGZMFD01QNBJR),CN=Routing Groups,CN=Exchange   
    Administrative Group (FYDIBOHF23SPDLT),CN=Administrative    
    Groups,CN=domain,CN=Microsoft
    Exchange,CN=Services,CN=Configuration,DC=domain,DC=com and open  
    properties paste the copied DN value to the msExchangeRoutingMasterDN 
    attribute.

In this issue, this attribute was pointing to an old Exchange 2010 server that had already been decommissioned. Once I corrected this, and restarted the Transport services, the issues resolved.


Happy Learning!

Thank You!


1 comment: